Please find here some of our archive case studies from our workshops at our old premises. We will soon be replacing this page with a more up-to-date searchable help page, but many engine running symptoms found here are still absolutely applicable to later vehicles.


Vehicle: 1998-R Volvo 850 T-5 saloon
Mileage: 150000
Symptoms: Uneven Idle speed affecting driveability

The owner had taken the car to the official dealership on a couple of occasions, complaining of uneven idle speed, especially when the engine was warm. They had run many diagnostic tests on the vehicle, but had come up with nothing. As the ECU had not logged a fault code of any kind (despite having fault codes for Lambda failure), they admitted they were stumped by the problem, and blamed its symptoms on the high mileage of the car. However, a high mileage should be no problem for a vehicle of this make.

Upon our advice, the owner instructed his local garage to fit a new lambda sensor. The result: all of the problems disappeared. The car has had no subsequent driveability issues and is still running fine. It is important to realise that although a garage with a ECU fault code tester may report no problem with the sensor because a fault code has not been logged, in our experience on a vehicle of this age the sensor signal has to be almost completely absent or very corrupt before the engine management will log a code.


Vehicle: 2000-X Vauxhall Astra 1.8SRi
Mileage: 75000
Symptoms: Rough Running, Unresponsive Throttle, Revving at 1500-2000 RPM randomly

The running problems had been reported to the owner's local Vauxhall dealership at its last service, but they denied any problems were showing up on the ECU fault code log. A normal service was carried out at 68,000 miles.

We instantly suspected a lambda fault. Why? Because for this type of vehicle it is a common mode of Lambda failure. Replacing the probe for a new one made the symptoms disappear. We replaced it with an identical OE spec sensor. No subsequent problems were reported with the car's performance.

The location of the Lambda sensor on the close-coupled cat Ecotec engine - in the manifold itself - had led us to believe most contaminants would be readily burnt off. Still, we suspect either contamination of the electrode due to oil additives, or thermal stress for the failure of this sensor. At such a mileage however the sensor had certainly done its job for a reasonable lifetime. Additionally, the ECU's adaptive mappings had become corrupted due to inaccurate sensor data. No evidence of other damage, either to engine internals or cat, was found.


Vehicle: 1995-M BMW E36 325i
Mileage: 82000
Symptoms: Erratic Idle, Poor driveability

The car's owner had visited several garages with no success, and got in touch with Lambdapower for advice.

There were few items left unblamed for the behaviour of the engine, which was that the idle speed would slowly cycle between 500 and 1500 RPM, making the car at best annoying to drive, especially as this vehicle spent most of its time in the city. In our experience, most techs when faced with Bosch MP3.1 equipped cars attribute this behaviour to a sticking idle control valve (you can remove the valve and clean it using an aerosol carburettor cleaner whilst manually operating the plunger).

Also replaced to no effect were the relay pack, thermostat and temperature sender. The cause of the fault was inaccurate information being sent to the engine ECU.

The biggest diagnostic clue was that the vehicle's engine had been having head gasket problems which necessitated re-fitting the cylinder head because of overheating. As a general rule, whenever a head gasket blows it is almost always necessary to replace the Lambda Sensor too, as the probability of contamination by engine coolant or oil is very high. Once the new sensor had been fitted the car was fine. As MP3.1 is not a proper adaptive system, corruption of the engine maps was not an issue. We recommend in this type of instance the efficiency of the catalytic converter is checked to avoid nasty surprises at MOT time. An exhaust gas analyser should be used.


Vehicle: 1996-N Fiat Cinqucento 1.1 Sporting
Mileage: 42000
Symptoms: Rough Idle, progressively worse misfire whilst at constant speeds

The car was admitted to our workshops only a few weeks after its purchase by the new owner. The problem manifested itself at constant cruising speeds, where the engine would start to misfire gently and require increased throttle opening to maintain speed. There was evidence the previous owner, or an unskilled technician, had tampered with the fuel injector, throttle potentiometer, and crankshaft sensors, but we immediately suspected lambda sensor malfunction and needed to do some testing.

Attaching test gear to the vehicle, a short drive confirmed that the injector pulse duration was being shortened thus causing the misfire, and a look at the lambda sensor output showed a drifting signal that showed a continuous 'mixture rich' condition when the engine was operating at partial load (closed loop mode). A look at all other engine management inputs and outputs revealed no problems. After a new sensor the car was back to running correctly. It is interesting to note that the sensor was performing okay at idle speed although the response was a little slow. This means hand-held testers would have passed the sensor as okay.


Vehicle: 1998-R Fiat Punto 1.2
Mileage: 50000
Symptoms: Rough Idle, misfire whilst motorway cruising

After our experience with the Cinquecento, which is equipped with the same fuel injection system, we had a good idea of where to start diagnosing the problem with the Punto. The fault manifested itself at constant cruising speeds, where the engine would start to misfire gently and require increased throttle opening to maintain speed.

After a short drive in the car, we were sure of the problem's origin and advised fitment of a new Lambda Sensor. The symptoms were identical to those found in the Cinq and measurements of the fuel injector pulse width confirmed this. All other fuel injection related components appeared to be functioning well, and there was no evidence of tampering.

This cured the car of its symptoms and it is now running well. It is interesting to note that the sensor was performing okay at idle speed although the response was a little slow. This means hand-held testers would have passed the sensor as okay.


Vehicle: 2000 Peugeot 206 1.4 auto
Mileage: 28000
Symptoms: MOT emissions failure, engine stalling, surging and hesitating at cruising speeds

This Lambdapower customer had purchased a sensor from the site and kindly got back in touch with us to let us know how he had got on. The car had failed the MOT test due to excessive emissions and was also exhibiting poor running characteristics at cruising speeds. The engine also failed to idle correctly and would sometimes stall altogether.

After reading the information contained on this site, the owner was sufficiently convinced that the Lambda sensor should be replaced. Upon installing the new sensor, all symptoms have disappeared.

The car was used for only short journeys to and from work, perhaps only three or four miles in an average day. This shows how this type of town or city driving can shorten the life expectancy of the sensor. It is certainly the lowest mileage sensor failure we have come across.


Vehicle: 1995 Escort RS2000
Mileage: 95000
Symptoms: MOT emissions failure, poor throttle response, generally bad performance

Another case of MOT emissions failure, the owner of this car had to replace his catalytic converter as the internal ceramic honeycomb substrate had collapsed completely thus making the unit useless.

After catalyst replacement, the MOT emissions was passed but the car lacked urgency and had general poor performance issues including unwillingness to rev freely and hesitation in the mid-range and at cruising speeds.

A friend of the owner directed him to the Lambdapower website, where after reading the information contained the owner of the Escort was satisfied the Lambda was at fault. We sent him a replacement and immediately his car was back to running perfectly.

©2003-2008 Lambdapower